R BATXAE T MCD2 (R I A L5

Bt A AP

(MCD2 #: & ~i14%.9)
(MCD2 # 4 % & i#.90)
CEFT X LY ET

G&S

.;;.'rél!: £ d&z-rgl

BRI vz Je 5 RHAT B2 )
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H o 1
MCD2 fRIEATE:
B L MPLAB IDE A et 2
. BB B 2
B =T MCD2 2 USB KSR T IR0 e 3
FPUEE . MCD2 W e 4
4.1 X MCD2 KB E MPLAB IDE. ... v 4
410 MR . o 4
4.1.2 TFIEMPLAB IDE. ..ot 4
4.3 BB e 4
A LA T I e 5
4.1.5 %E MPLAB ICD2 /E AR T H oo, 5
A.1.6 BEE MCD2. ..o e 5
A4.1.7 FHMCD2 e 6
A4.1.8 P T E 6
4.2 4 MCD2 25 HARB AR B () s o 7
4.3 4 HBRA — AR IR AR 7
B HEE . MCD2 S e 8
B I B B
HI/NE L MCD2 ML ICSP Z BT o 16
6.1 BPIN LU AL 16
6.2 BPINEREZ U B e 17
H-BEE . MCD2 T IERE IR e, 18
% )\F . MCD2/ICD2 2 QL1201/1202 iifi ke 5 & il gs (i HHRma . ......... 19
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MCD2 PHEAN T4
$—%, 223 MPLAB IDE #ff:
11 e ANEERAELE, R RO B e B A A I IR P, T
FEHAL F\mplab ide SCFJ2, #4447 F I MPLABV6.X X .exe 5k # MPLAB
V7.XX.exe FFaf 24 AT (HEA FHBCHT RO IR 3R «
1.2 R EPAT IR I 22 e, 225 R EHT R B v AL
*x VTR AE WINOS R 452225 1E6.0 I35 N, MPLAB IDE 23 5¢ 5 1Y
FIE WoRTB B SCfm, B IE6.0 4544, 2 J5i247 MPLAB IDE 4 I dE
FERAE R IR Y (R v B R R e 3685 7 IR N 1E6.0 IR JEIE T A
MR, JER I AEREFEEAAEME] WINDOWS [y, HEHAT
C:/Program FilesMPLAB |IDE/dllegister.bat {ff 1] fi y i) i, ) ***
***Windows xp #1E R 48 AT g 75 ZLA B DA FRA™ BE 1IE A e % R+
W LG RAFASREST TP BT, P RE S e B e 2 5 i 25 25 2k, 1K
FUE R B BRAT W3, “ H AR TR — R BT N3 MPLAB IDE {15 4% .
FoE, WERORBEM:
(A A P e B X —20)
2.1 SEANELERAGEE FTIE BRI BRI, $AT “IihlimpR 7
RGN QT —Rhh WX, SNSRI
“Uii [T (COM F1 LPT)”, "L Ui AEAFAE 1 LA sty 11,
2.2 AEKEXTFATT MCD2 B FH ) L AT 1 B R R W B LA
MCD2 DA% & X A~ 1l USB 1), XUk 3R THAf T F) A 10 a3l 3 S
1 (COM1) », MemPEaaiy cCoOML (st Eal, BN “Im ik E” —
£, K E O s e o ek, N

2%
w WOl | SRR |l |

Ll

mEtem ) (125000 -
mora B =
-1 T e
e i =]
mrm g EE - |

i | EEmiE |

%2 0
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COM1 IS EE

MEEE AR B ) £ TE % ] A
ERE R EL R,

FETER T (R (R (L)

iR (T {1

CON BRES () Icum v]

23 fii “Eg (A7 HEANG PR E R 1, CHH A FIFO 21X,
RIK R TR 250, dn L

2.4 BRI LG Sh e B sgneE, Bl e Bl DE
PEVEE, SIS A A B IX DA R4 T b

2.5 T S e A PR B A AL (R ) ) A R, iR
B

% AT HR TS 5 B0 R S (1) HR 1 COM 2 T F s e e+
B=3. USB BHEFRRE

3.1 I BEHLAC S (1) USB 42k 14 3 MCD2 L2 HUIK, 2o AN FH P R
3.2 USB WaENFE 71 2t B WL : (PIC16-MCD2 {1 FH U Wl 5 ) 155 20 1T
- 23 11,

MPLAB IDE V6.XX ] USB BRBHFEFFHLE -

X&) PAE Cz/Program Files/MPLAB IDE/Drivers2000/1CD2_USB -t
H ™ (WifjE windows98/ME, N4 icd2w98.inf, #£ C:/Program
Files/MPLAB IDE/Drivers98/1CD2_USB FHEXF) .

MPLAB IDE V7.XX ] USB BRSHFEFFHLE -

IRB)FEFAE C:/Program Files/Microchip/MPLAB IDE/1CD2/Driver/
T H T . (X )LERIA MPLAB IDE ‘%31t C fif, WIZR/KR¥ MPLAB IDE ‘%
BEAE D AU Y (1 bk 250ak D SR AT)

R ANEAE2 3 MPLAB IDE HPKf MCD 2 5 PC il USB #E#%.

M HRZEWIE, IT2AWINTLERE, RERBERICHFTF
FREA, FHFEHREIRS) - FHE R IE R SCYE?
3|
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2 MEEIXAN RS, AT DUR SR R T, HE T TR 10 R
. TERGM BB G, A, WEAESIERTD. RIGEFREA,
BAMFN R PEPRRELE. SRFERE WH AT BT, A%
R VIR, HEARIIRB SO, ERERERE . )
$IE, MCD2 ¥I:b
(X — iR FK K MCD2 () S8 4% &)
4.1 %% MCD2 kit & MPLAB IDE
4.1.1 BEER(Z RS- LEP I “OitEg ik ]
o JH USB Zkak i M4ki%4: PC 5 MCD2 1HL, Jf4 MCD2 i EL gt 4h
BB OV HHE ;
o JH 6 UKL SLE —diHf N MCD2 ML, 55— dinddi 2 H ArH 1ICSP #:11
NCD2 1) FL4% 11 (7 7= H Ao L 0 B U 9l 5 B ),
VE: 6 2] LLEHEK MCD2 45 31 H bsbid, AN 75 20 B3k G4/ 5 1
R T EE A ESK) . H PRBCAE AN 75 T —AS 6 .5/5 it ICSP 4%l
Bl (A RB3IAHED) BRI v LA /S5 o
FFHER: /£ MPLAB IDE 12170, ANZWIF USB MGk 1 HgE, 5
W T 7] g2 550 1CD0019,ICD0021 4 iR & .
W W T USB HL g5 sl it I i 4k, i 5GiE Y MPLAB IDE.
FErG A USB M40 5, NSRS ) MPLAB IDE(F5 25 S 55 [k
WINFEAE), B8 8 M Aity, DRI ARGkt USB IR 75— BLi 1A .
BRGS0 T Rk R USB sl ep T 2R IR 200558, (HAE 2R (ICSP)
FEL 25 R R 4 e W T i
4.1.2 FFi5 MPLAB IDE
1E44¢5¢ MPLAB IDE 85, AT N T —F ke she:
o« P FFEE>FE/F>Microchip MPLAB IDE>MPLAB IDE.
o Xt R HIMPLAB IDEE bR
« IITMPLAB IDE% 342 F\dlls 1 H 3% F ffimplab.exe.
4.1.3 HEERMF
A F 284416 6115 HE Configure>Select Device Sk MCD2 2151,
() 2 (FAT1A 7] QL200/MCD DEMO S5 b il lic 214 4 PIC16F877A,
e A PICI6F877, AN & 554 AN (R 24 4).
VE: MCD2 i S HF #4578 Microchip T H 7 R %% MPLAB
ICD2 54 — ST BIRR AR 2SS — NI BIAR. 30T s
5 4 5
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TR T LIOERE, e S ELepg], raeiEs T TIE
{HE AT LLiE MCD2 54725 i .

41AREFHRE.

1 FH B Pk B AHEHE Configure>Configuration Bits K% & 41l
T H MR B
« Oscillatot $i&3% /7 :05eHe, MR A BRI T RE, Ak 1)
MCD-DEMO # i) BRIN A 4M e r ik, FAl Tk 4R35 77 20k HSIXT .
« Watchdog Timer & Jf{EREN,, I MCD2 E IR T = IHZIm— ¢
PLEFEA off
« Power Up Timer FHUENATREAL, —BIEEAD on A4 T ik,
W AT UIEAE off
« Brown Out Detect s HIE M RES, F MCD2 /R T H N —x
PLEFEA off
» Low Voltage Program fikEZ4feflifE, H MCD2 W — @ Zikde N
Disabled
« Flash Program Write =5 FLASH flifig, H MCD2 fF ik T =i —
EE LR N Write Protection off
+ Data EE Read Protect 24 # EEPROM {3747, F] MCD2 1F i
TR —EZIEFN off
« Code Protect jn#fi, H MCD2 #EIHR T HIN—E Zik £ h off
4.1.5 % B MPLAB ICD2 fEA AR T A
1% Debugger>Select Tool>MPLAB ICD2 ¥ MPLAB ICD2 1£ Jy i
RTH., —HIXANT B ik, Debugger 2 Ml MPLAB IDE T.H4%
SR RRIE D [FIRS, OUTPUT % &4 9F, KT ICD2 RAFIE R
M5 D2 BoR7E OUTPUT % . (37 ICD2 /E IR T I prkes
IR LR 105 B, ARt iU A, 5 22hes se iy LAl R
W 22 %k % Programmerr>Select Programmer>MPLAB ICD2 ¥
MPLAB ICD2 1F R &fe T 1)
4.1.6 % & MCD2
B—WAFERH MCD2 ## H MPLAB ICD2 22557 S35k % & MCD2
4T Debugger>MPLAB ICD2 Setup Wizard kiz17 MPLAB ICD2
¥ 5
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24 s R T R B A T (R TES % T
MR ), R i “ SRR R S .
F:l:um Fart

use =]

Baud Hate
{I = !ﬁﬁésﬁﬂﬁi#
| 0SBk 2 02k 4058

oM
—cnmz R w2k 454 FayCoMl 2

7 Target haz awn power supply [ Pl A CagEiR
% Power target from the MPLAE ICD 2 B £ 48 %% % A MCO2

[~ MPLAR IDE automatically connects to the MPLAR ICD Z
MPLAR TDE flshif4E3|MCDI (—#E k)

v MPLAB ICD 2 automatically downloads the required operating systen

MDD f b TR E

DL BB 2t 1 n] H 4% 7F :Debugger>Settings ) Communication Ft[f].

LS o S HL Y5 132 B 1T L B2 AE _Debugger>Settings [ Power FtHI.
4.1.7 BHr MCD2 E - EER L)

4 MPLAB IDE (WA BLZAFIRERE,  FTRES 7R — 4% M5 R o [l
PEFFEENF. MPLAB IDE K H 8l 2 B8 Il 1. S B6s i A T B s

ICW AR [CD2 s aboud b downicad a new opedalicog spten I
MPLAE 2 pst slarhng il wil sppear bo “hang' ot b splach screen Plesse
be patieri. MPLAE wil fimish i’z itialzation afer the 05 i dowrdoadad.
[Nobe: *f'ou maw vaish to select boignone thiz saming in (he hiuae.)

[ Dan't dzplay thiz warng agan

0K

[A B,  ANE Y MPLAB ICD2 B H TANFE & 5101 PIC B HL, 4]

HATF ) PIC 57 ALt A] 8 L XA 0 THAE.
%6
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I A1 A LA FE S 1T P20 3R T 0 W o (LB A FH 8 o 75 - 3 S )
1. %+ Debugger>Download ICD2 Operating System. ik %
ICD2 [l SCAHEXIEHE S FT T
2. M\FIF b E) YA R e R R AL A SR, SO AL R
icdxxxxxx.hex, 1 xxxxxx HIRAS. & MPLAB IDE #&fitf
BRCAS )15 AT LAY F README (445 MPLAB ICD2.txt. fi 4 %
PRI PIC S8 PFRA AT RE AR ).
3. i Open. MPLAB IDE ¥ U8 144 & 402 MCD2.
4.1.8 NHHE
EFXE MCD2 F B AR VF 2 IBLE, T TR IX LU0 B O
o M USBERENT, USBHIAMCD2HL, (HANRELS B ARb b,
B H PR R L JEK HMCD2, sl A 45 MCD2 EH L% — AN LELE AN
OVHLJK,
o M HRS-232 % H: BIPCHLIT, MCD22AZi4:— NMMBOVHLIE .
o MMCD2T—/N H ORI HIERS, B AT LU AN H PRI ESV L
PR e A LR, B A] ik 200mA (A4 7] ffyMCD-DEMO/QL200
A sk AMCD2 ENLA HLED &
* MCD2ANGEHT H AR k.
o WO B SRR, R4 H PRI HLZ 11, BG4 MCD2IHL
4.2 HMCD245 B FnR At v b i) _E BT
XANECE N AV S TAEAESY, i 200mARLGE FAEA
1. #AMCD2INAME R 4 4r 5 i iE (5 2k, s 2k #MCD2
FIHARR, (AZEL H bt ).
2. JAZIMPLAB IDE, #T58 H4.1.2---4. 1.6/ 4 1%, 1HiE4.1.6

{~ Target has own power supply

;J/I:g% ':F' %Eilﬁ%ﬁﬂ/ﬁ . {* FPower target from the MPLAE ICD %

3. 7EMPLAB IDE[JDebuggerz¢#. F, £ Connect.
4. WIS HARBUM N %2543 2 HMCD2E HH RSV RIS T, 35 R REE1FA
1T,
4.3 4 Bt — AL IR )R R
97 5
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ST XANACE, HAR AT LAE 3-5V, HLfU AT LAEL MPLAB ICD2 #2144t
(PR e A O B T A A E bra A A FH ) 4 R Y L
1. ZYMCD2JnAM I % o 5 i s s 2k, FRIEZIEHMCD2
BIEHARR, A HbrbgE g,
2. JAZIMPLAB IDE, #4752 L1fi4.1.2---4. 1.6/ L, 11E4.1.6

%" Target has own power suppls

S IE s = U E A " Power target from the MPLAR ICD 2

3. 7EMPLAB IDEMIAZEH T, iE#Debugger>Connect (X Al g
/\hTOOZOE’J’faH:, SEAHELE).

4, fEENEIG, 4y B L, 2R )5 Fk#Debugger>Connect.
BhE, MCDZ%E&

X E R 248 912 med-led1.asm KA TT K — a7 B TRk 2.
XAMBIFELE MCD2 (17 S LG ) MCD-DEMO 4 SE 451 ST e ]
PAERE. XA A5G MCD-DEMO 37~ H Kk S8 PIC16F87X (113
IKKT A LB TE R AR B H BB IS SR A R B TV T

5.1 3044 B oCH- bk BT
e BEHLACED AL R i med-demod 4 5151 SCA AN 52 ) 21 v fi P £
EL N O 3V SR R D Rl o P ol e ot (154 € O A A G G
ﬁwwumyiﬁﬁﬁiﬁﬁMiﬁgu&i#ﬂm7%3ﬁ¢iﬁ?
R H), B i 25 B SCPEI N AT SR A s s
5.2 AT ER DU 224.11-4. 1610 T AT 5 B e 4 5 82 T 4P MCD2.4%- 348 T
ALK 8TTA
EEFREWNT:
« Oscillator — XT/HS(IX &£ XtMCD-DEMO. & S Af FH e 1) H A
B, AR AE AR AT AH Y 1R A )
* Watchdog Timer — off
* Power Up Timer — off
* Brown Out Detect — off
* Low Voltage Programming — Disabled
* Flash Program Write - Write Protection off
%8 L
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* Data EE Read Protect — off
* Code Protect - off
53 Bf LERS
XA TREH,  MPASM JI g gs 2 gl fii .
1. %% Project>Project Wizard K #: 37 2 — A4~ L.
2. BRI AN AHEHE,  PICI6F877A NiZgik b (#5 ¥ ty, &
FHOEFEL A PIC16F8T77A).

3 R B AT R 7] BN — A X IEAE & B MPASM {EhiE S T H.
fE"Active Toolsuite” F$751F& hik$E"Microchip MPASM Toolsuite”
A MPASM. MPLAB F1 MPLINK # &7/EIEMFIEE1E s MPASM N5 &
#] mpasmwin.exe, MPLINK {5 5E £] mplink.exe, MPLAB N5 /€ %
mplib.exe. 73 FU T 8 8 2R G8 AN B8 A AT T4 o TE 0 R b 17 H B 21
bR, XBUR A TFENN LR ik, T ek b 4Lt bR T,
SR JE s NI Location [X 11 Browse $%4H, #62EAf 1 bk I s wh 47 IF
(— M AN SCRAE R — N SO, a0 IE A SCEF I B ARl B (8 14k H A 4L
bRE SO ERAE), BRATIER G A AL A R bR T, W F K

Step Two: %
Select a language toolsuite /'@

Active Toolzuite: |Mic:r0c:hip MPASM Toolsuite Li

T oolsuite Contents

MPASM Azzembler [mpasmwinexe)
MPLIME. Object Linker (mplink. exe

MPLIB Librarian [mplib.exe]

Location

C:\Program Files\MPLAR IDE \dllz\MPlab.exe Browse...
Help! My Suite st Listed! | [ Show all installed toolsuites

O e 1)) |"F—‘f_‘5‘ ) >| HRH #EEN

%9
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=
3(1:‘:'-#: r[-il_/p

any eeiating filas yess prejast

ﬁ msac-aefl asrs -.I |
M medwomi.aem Ardd s

B rmodebe s
[ modHodl. aem P ]

M ki mam —I |
[E MODACO2 000

B MODACDZERR

B MODLCDEHE= —1

B MODLCO2LST

U oot it e

M rcc-ed OO0

B el pr _J:J Chaszk. tha biec bo c2py the Be o the
Led P L oot demcion

ck—p@[T—Fms] mm | |

M N0, BN TR SCPE R H 44 DL R BRI E S e Gt
WRAE BIERR 7 [/ — NS0k, TH 46 R 85 2SI B AN A S 7
Bo) B TR SO 2 1) 3

M N0, BINVE SO, AT BAE R RN, SN,
Wil A 52 I 7E R4 i med-ledl.asm, il med-ledl.asm Skikde, &
Jii mih ADD>>¥ e 24 L bR, a1 B,

w2 XA DRSO e i, s se OB H 1)
54 HEFTHE
B S5, MPLAB IDE % H 220 TR N AZ W0 R TR

S e ot men DTSR

= mcd-led1.micp
- Source Files
© e mod-ledl,asm
i--Header Files
i Cbject Files
i Library Files
L Linker Scripks

WA R, XHTUFIHRREME TEE . KOs
F”Source Files fifbrA ik T Add Files SRS Scff. B —AN L
i, wTRGEIE e, ARG s bR G T Remove MCTRE H BRSO
5.5 filjE HEX 3XfF

BRI — HEX 3C#F,  E$F Project>Build All 3k7F TR
PR TR A 7 b i A B IR IR (S . B 27 Build Al 2 P UK.

% 10 |
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MPASM I g ik 23 LL.asm SCERARTRNR 4 A2 i — A hex A
PRI SFT I —ANIRESE D, BoRgmBEmEE S EEE R, s R

7Rk “BUILD SUCCEEDED”, #i#&/mawmiktl T .

5.6 W EHEHRR
YEFFHEIRET,  #iA MCD-DEMO sl I HET % &

o fif FHIBREZR L PEPRS LI A AN AM iR .
o AR ASM SCAF TR Bl SR EE 7~ e B ARG TG Sk ek -
o WHEHAR EILE B, Pk pesk. ...

5.7 BAERAARS

1#¢ Debugger>Connect ¥ MCD2 5 PC @t ri%$:.

FEEIFEE HIL 1CDWarn0020 kA2 H Aras s HIIX TR I i A -
L PR e A R IR (AR Pk B S R R 5 H
PR = —E0
2.5 K5 BN M FEEAE R (K& MCD2 FiH bRbi 1 2 2 15 155D
3 YRR B AT A, A S H AR AR R YR A SLAS RS, T BLER A N
AN OV LR, (RIS A AR AR B R H Ty SR AR S S bRk B AT
A5 H b kil Can St i CA R ], AR B3R
5.5 F I 51 I (MCLR,PDG,PDC) £k i#% I f& 7545 Hi 7% 5 i s ol — 4
B WA, T BRI H AR MCLR 5| E #23E 482 VDD 15T (I
 MCLR NiZi@ ik 10K HiPH 473 VDD,

BHINIIRIER L (1ICSP) & A7 Bl )7 BBz S BB H AR s 5 .
735055 /D 5 A P 75 2R T SR RE K.

VE: W BRI BERAF TR AR, B H SRR
16F87X(A), WA AL ST 1T ) =A™ v

1% $ Debugger>Program ¥ 4 i fe /55 iS4 fE 21 MCD-DEMO i

B PIC16F877AGE: PIC MIFEL Ay Bas AN [F T e sids, el

L BT AN FF EEPAT G B A, 1T MCD2 7 47 B I A6 20 AT

Debugger>Program # #1275 AR # S 3t H A5 5 A e 0/

Wr /A A AN 1F) S FE v] R R 2L EY, AEdmtid fE,  OUTPUT

23 W EAER S HTIT B, AR e T, R HE N AR B R,

%011 0t
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=0
Baild | Find in Files RFLAF ICD 2|

Eo-Progromming Debug Vectoer =
«Programming Configurstion Bite
[Ferifying. .
e Progrom Mmooy
ko Db Fxeaut ive
1 o Nebngg Veotor
s Verify Sucessded
Lo -Progroming Configuration Bits
. Confip Msmnry
Prograsming succesded

r\m ID 2 Ready -
| | ¥

RFESE RN BN | CDWarn0083 Ji ik ik A i i =t
HILZERES, —BCAIRG AL, EFARLE 3R 7
e HAsBOE SR, e R HARRAEEA L. RS
PRI« 505 | E P 75 22 R PRk A BRIEA T Ui
GRFESERAN R BN | CDO161 $2/R-F8 S K6 AR, 1A -
Connect %4 ICDWarn0020 %45 ;  H x5 1) MCLR/VPP Ji |
WA B ERraM A i CHLe B2 A7 s R Bk AT R 29D 1CD2
5 IO VG B AT 5 P Rl SR ) B s AN R T LA
FROL R 1S L
5.8 14T MCD-LED1

TR AT DU 35 AR A R AR )

Pk THR: A ik T HR A
Z17 [ BB HAT T
Hk [r1] A7

TGS RN (HT g : T 5.1-5.7 ERAE):

1. FJF asm SCH(AE TR 1 X Sof44 5 Aid ] File>Open).

2. i%¥$ Debugger>Run(ak & T HA% RUN $441)

3. fEHFbRM EMEE TR () TAE R FE.

4. #%$ Debugger>Halt(al 5 T HAE HALT #4)  1iERE g7,
5. %E# Debugger>Reset & i/

5.9 A3k MCD-LED1

%12 it
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I T A AT T 5 BEL L R R PR AR A

o HERBR MRS IT G Bk 152 B AXT

o RIFHHATY% 2 Debugger>Program 1% .
MR A AP A IOCRIRAS, v AR P AH DG A B K

1.

6.

7.

M med-ledl.asm ik HECRE AR SR 7E BT AR T — AT
btfss  flag, 0 s FIWbRGAL, LB EIEA A
AR, ORISR,

M S ik $E Set Break Point. 3X—47BLAEMARIC A T (L0 4 1)
B {5 1-kRid). a1 K B R,

1% $ Debugger>Run (&) i THA: RUN 422401 LASE I X i Gs 1T

FE e AR PAT RIS AT, WSS B R IIEtT. SRim, BIFEA
Sk,
4% Debugger>Halt(8 itk THAZ | HALT $250) sk - F2 5.

I oo micd -led) s

| gt e o
Jil—l wi re =R R T L i R '_ILJ
mwatch =10l x|
AddSFR_|[sDcoND ] Add Symbol[fag =l
Lddress I Sywrbol Nate I Value I
ooz s £ lag 0s

['waich1 ‘watch2| watch 3| watch 4]

FE AR, %£FF Debugger>Reset. #4354 N i% W oRa NG

T k.

FIHF—ASHH S 6 R MR P HATH FLAG Zifiss{E ARk, ik
413 L
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¥ View>Watch. METEHER Watch iEH4TJT. W70 Symbol 5%
HmpFRPIERlag”, RSG5 S Add Symbol” flag #% 7 02
M 1 1.

W MR H Watch % 1, WS EST T Zifras i D2 A

SRR K 2 1136 % MCD2 iR 12
8. HULIATRERS, i%4% Debugger>Step (2l & T HA: STEP $44l).
9. TEMLERE Lk & A A2 4% FLAG 1A,

10. ik FFile>Save 17 1.
11. % Project>Build ALL Fa TR, —4f5 BA L R g d g ar.

PSR AR, MCD2 i B AT Debugger>Program.

12. i%&$¥Debugger>Program Ffi4ife. 4MPLAB ICD2X] i HE i
7K’...Programming succeeded’, F&/3 5t il LAFHE N IZfT AR
13. fEZ BB E W S AT S A B, EFERemove Break Point# i A
14. ¥FDebugger>Runfii fFEFEia 1T 7 S R
TS brgn S ARG AT Re SR 2 1. FHMCD2FIMPLAB IDE
RIIRE, EREIRPR I A B IHAE SIX L n)
5.10 %2

YRR I RS AT, N D R AL R i
BUZAT. {EATX 00, # MCD2 5 I R il s H

PN REATSAE, o] LRI A R
1. ¥ Debugger>Select Tool>none 5 MCD2 1 ik 1. H.

2. {f Programmer>Select Programmer ¢ k£ MPLAB ICD2 1

H ey
3. ff Programming>Settings F2/Fhr%s L & H T =40
4. ¥ Programmer>Program.

ARl R (S R BE A LAZ AT T, FRATT AT LAY programmer 25
T Release from reset @4, HisBiadi NIk A1 0T LA
Wt MCD2 5 P i i W il e de 22 9145 FH b b Fo RO SR e 13 AT
fER MCD2 ¥ AR R T RMBIEMTFREWT:

Ll

283 MPLAB IDE, E£EUFHsAF, 1 & LF CONFIG fi.

¥ 14 T
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3.Debugger->Select Tool->MPLAB ICD2
43T Debugger>MPLAB ICD2 Setup Wizard
% Debugger->setting-> ... 5 B U 1L,
S TREIFBNIERE
6. Build All
7. Connect to MCD2
8.Debugger->Program
9.Debugger->run
WARA Read {5 fr, SEMEMOEREY . SHOOILE S BB E S 6. 8.
9 A ER.
B 20T i) {3 A if) MCD2 A BT IEASE T HER N &, ki
W AEA B 5 RS
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HERNE, MCD2 EHLBLEH

1 ;i .‘_T

PIC16-MCDZ2" |
[i4 CimCuiT Bemussns]
2 — O

Bl s

| LAES N.B NN N www.phe 16, com

1---RS232(H )il fF %8 1, Wi FEALALE AR 258 MCD2 2| PC
GINORE BT
2---USB S {74248, LIMCEF MCD2 #:% USB 2 fiz H B 1CDO0019,
ICD0021 $&/~ it ik #fi USB LUK SR M ah e, BAE I T 2%
MRS, S5FF 8 Bb At Fhddk, RInISe sioRahEna, ks, &
SLIBAF R . OEANEAE USB IE & A5 IGO0 IR ALF5)
3---USB iz 1, Wik USB #4525 PC ik USB 15,
e W AEEH USB 5 H M8 MCD2 | PC.
4---ERROR i8], 5--BUSY igfTHfg48754] .
6---POWER HLJ5FE /AT .
7---1CSP i th T # ki i 2 1.
8---MCD2 4z % A [, i& T AC/IDC7.5V-12V, Hi i KT 200MA
RIAME LR N (ANTR 5 S H R I IE AR
6.1 6PIN EBELUH A

MPFLAB ICD 2
N Connectar

Target
VEF/MCLR Vssg PC Board
Bottom Side

16 i1
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6.2 6PIN EELIH B
1. ABCERNF
JEiEH: MCD2 2| PC, %64% LIPS A3 MPLAB IDE #fF, (s
Ja AR bR
2. NUIEHE B
LRSS N TR R I BRI 1, 7 (0 B eI B MCD2 AT E Aidi . #5
PRFT S AR F AR, A AR N I P 1% 3% 1

1-B846
f AE4BEREELY

1—NCLR. .' /_
3—VDD ' ;s
3—GND
4—PGD ~_
g \ TR 3mss B POD BESH RB7
6—LVP-ENABLE % R POD B

N EERAERE PGCIEE A REG

F Bl ERTE e R~

%17 it
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B-HE, MCD2 B
WRER T

D

2)

3
4)

oo = =

JLEsEES ’-' | 1
I £ - -
|[ - EuRE T _z".'. Tl '
\-:'.:l- r.'m E} E—_’_ e oy
i HGR- =T,

o
=l =~ [
H

¥

P A

HED TG

17 L g e 5 ik E A5 1 USB 2Rl ep 4%, o1 S H ARKCR: FH 5 2L
SR, [RGB R IR AN OV HLYR.

W BT ELIY 40 S P i PICI6F87X (A, 1B HAREA AL, Hik )
MCD2 i Bk by Cln SR B BV B A2 28 BIfY, i A X1 40
S R VE RSy, BB 40 S i 5.
FHBCER i~ 6 O 43 MCD2 1Y LRI Bk IE# .

15 40 BTGB ML, i 2 4% 20 BddAT, 05 Bk 5 H bRk _E1 40
JHI1C 375 R R A, W SR 28 IR R L, BfEEh T 2 4% 14 1
W, CBTE LS HFRHR Y 28 I 1C PR R AE .

WREE R — ()

SN

'!-~.. (AR ==
. ﬂ‘\; A —_ .::%:--_ .
- HeEE b = =l]

e = —] H

LT
=
_ j WCO-DKMO

(5 =

1) 7 B8 T VB 5 VI AS FH fUSBZR B ER 114k, 4 S H AR BRI )7 L 6%
BEr, [ LR T B AN OV LY

2) FBCER fi P60 H 45 4MCD2 = L3 H FRii

3) fEHARR L E AP B . PICI6F87X (A) [ #l.

418 il


http://www.pic16.com
http://www.pic16.cn

YNz e 2% B TR PR A ) WWW.picl6.com WWW.picl6.cn
#)\FE. MCD2/ICD2i# {5 &R
vE: QL-120 A3 WRHIEBCAEH T ES I (QL120 A3 EHAR G &R
TR (BRI
1. HiE#

e A0PIN 231 28PIN #3f 16F57 fr4h 18PIN 281

IES
BEE

754
R
ER
FW
P E)

14PIN 2844 16F57 10FX X
" B4t

3---ON 4----ON
He 4 OFF He 4 OFF

]
s L Fea L R Fentn T

= |
0
u|
|u |
m]
||
= |
n |
= |
m ]
=
i)
=
1

e
-

019 1


http://www.pic16.com
http://www.pic16.cn

VR ¥E e B i PR TR A F WwWw.picl6.com www.picl6.cn

2.0 Fr B R
W B A A (08 5 T VAT R

T A G T T A A ZIP B e e, B R PR I
VR AR TF R v ) B dd g F—FE.CE M T 1) KHtkE A r=).

T HAEAEAR PCB AN B e S (AN F7 28 SRS IT ¢, AFTIE R
#8), ke KRR PCB A TE AL, WFEEIIIALE, HTFRRE,
SRIG RS BT GEH 77 S R sl M), RS 18 7 47:S0T23-6
JE#54F(PICLIOFX X X) SO-8 #3444k SO-14 FA1l. SO-28 I3 aeff.
FERRIEAL Y SO-28 £ 8F (PIC16F57). QFPA4/PQFPA4 5 g8 f1f |
PLCCA4 £ 8801, TQFP64 H s 28}

IRE T R

1. HEPIFEAE(MCD2ICD2 ] USB/ R 4 HL ki, 4 MCD2/ICD2 fit
SEB OV HLYR, I HIE 4% MCD2/ICD2 558 5 36 il 4 2 47)

2. 4% LRSS MPLAB IDE %44

3. kT2 (ConfigureaSel ect Device)

4. IWNFERSE I HEX SC/F(File-&lmport), B 3 TR a4 34
Po vE: HEAFHAMN HEX L ViewaProgram Memorya )
T 11 /6 M I 3] Opcode Hex

5  WEHKCEN (Configurea Configuration Bits)

6. & S5 T H & MPLAB ICD2 ( Programmer& Select
Programmera2.MPLAB ICD2)

7.  WELF ICD2/IMCD2 %2 % (Programmer & Settings& Power (K Power
target circuit. .. i H 1443 )& Communication 1% 41 it [ & i [
B H 5 E.

8. WEUFE I IC A AR A IO

9. TEB{RE FCE I B S 1 i &Connect(PASS 5 AT T 11 1) ik
B, RO e 4 U]

10. Program(%%'5)

11, A RS B S AN B AT Program(BE5)
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